Synaptic compatible avec Wayland

Il y a quelques temps, un peu avant la sortie de la Debian 10, il fut question d’abandonner Synaptic puisque celui-ci n’était pas compatible avec Wayland.

Tout c’est accéléré ensuite pour faire en sorte d’avoir une Debian 10 avec synaptic, grâce en l’occurrence à un subterfuge.

Aujourd’hui et alors que beaucoups annonçaient ce programme mort, il ressuscite et propose le support de Wayland.

synaptic (0.84.8) unstable; urgency=medium

 * debian/control:
 - update recommends of libgtk2-perl to libgtk3-perl
   (closes: #891877)

-- Michael Vogt <mvo@debian.org>  Tue, 15 Oct 2019 06:58:08 +0200

synaptic (0.84.7) unstable; urgency=medium

[ Boyuan Yang ]
* po: zh_CN.po: Update translation

[ Michael Vogt ]
* Allow running synaptic under wayland again. Wayland supports
    this now since Gnome/Mutter 3.34

-- Michael Vogt <mvo@debian.org>  Sun, 13 Oct 2019 08:44:26 +0200

Voila une bien bonne nouvelle pour cette application qui n’a jamais eu de dignes remplaçants.

Petite correction de mon ami Tnut (le papa de NuTyX) dans le forum:

Petite correction:

Wayland compatible avec Synaptic. C’est en effet wayland qui s’est adapté aux concepts (aujourd’hui dépassé) de synaptic et autres. Grace à cela Michael Vogt (seul développeur de synaptic, tiens ça me fait penser à quelqu’un d’autre) a pu faire marche arrière:

https://github.com/mvo5/synaptic/commit/c3e63ef5430c916f15a580c06baceeabf9195061

Merci pour ta correction.:)